1

What Devices Are Compatible With The Cove App?

  • updated 5 mths ago

IOS

iOS devices require a version of iOS 9.0 or newer; the app is compatible with iPhone, iPad, and iPod Touch.

ANDROID

Android devices require 4.1 Jelly Bean (API 16) or newer. The app is compatible with 13,591 Android devices. If you are not sure if your device is compatible with the Cove Security App, please check with your Carrier.

Related Articles

Recently Viewed

Home